Enom Support number experiencing delayed response issue
Incident Report for Enom
Resolved
The issues we were experiencing with our phone vendor has been resolved and our phones are fully operational again.

We are very sorry for any additional delays this disruption caused to anyone trying to reach us by phone.
Posted Oct 04, 2017 - 07:39 PDT
Investigating
We are currently experiencing an issue with our phone vendor, which may result in the inability to connect to support by Phone.

If you are currently waiting for one of our agents to answer your call, please sit tight as we work to get the problem resolved.

We are very sorry for the inconvenience and we hope to have this resolved as soon as possible.
Posted Oct 04, 2017 - 07:32 PDT