Email Service
Incident Report for Enom
Resolved
Email performance has returned to normal levels. Inbound mail remains delayed at this time until the queue is cleared.
Posted Feb 12, 2018 - 08:23 PST
Update
Some users will be unable to login to webmail, use POP/IMAP, as well send and receive mail.
We are working on getting full email service restored, thank you for your patience.
Posted Feb 12, 2018 - 06:49 PST
Investigating
Our operations team is investigating an issue on Cluster A impacting webmail performance as well as sending and receiving.
Posted Feb 12, 2018 - 06:39 PST