Radix Registry Errors
Incident Report for Enom
Resolved
We've been able to resolve the matter related to the registry outage and can confirm registrations and renewals are successful now.

Incident Start Time: 7:10 AM PST
Incident End Time: 8:40 AM PST
Length: 1 hour 30 minutes
Posted Nov 19, 2020 - 08:41 PST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2020 - 07:23 PST
Investigating
We are currently experiencing issues with processing registrations or renewals for domains under the Radix Registry. We have engaged our operations team to investigate and will provide updates as they come.

Affected TLDs: .TECH .PRESS .SITE .SPACE .STORE .ONLINE .WEBSITE .FUN .HOST .UNO
Posted Nov 19, 2020 - 07:10 PST
This incident affected: Domain Services (Other gTLDs).