Payment declines on Enom.com, EnomCentral.com & BulkRegister.com
Incident Report for Enom
Resolved
We're happy to report that payment services have been restored. We are no longer seeing errors from our payment gateway provider.

Transactions should be processed without any issues.

Thank you for your patience in the matter.
Posted May 10, 2018 - 07:46 PDT
Investigating
We’ve received a few reports of payments failing on Enom.com, EnomCentral.com & BulkRegister.com

We are currently looking into the issue and will update when we have more information.

Thank you for your patience as we look into this.
Posted May 10, 2018 - 06:16 PDT