.SG Registry Connections
Incident Report for Enom
Resolved
We have not encountered further delays in registering or renewing domains within the .SG registry, and are marking this incident resolved.
Posted Jul 24, 2021 - 14:21 PDT
Monitoring
Our connection with the .SG registry has been functioning normally and we are monitoring registrations, renewals and management of .SG domains.

For a list of affected TLDs, please look the registry up in the following spreadsheet:
http://enom.help/chart
Posted Jul 24, 2021 - 08:55 PDT
Identified
The issue was identified and work is underway upstream to restore service. Thank you for your continued patience.
Posted Jul 23, 2021 - 10:35 PDT
Update
We are currently experiencing connection issues with the .SG registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .SG domains. Existing domains will continue to resolve normally

For a list of affected TLDs, please look the registry up in the following spreadsheet:
http://enom.help/chart
Posted Jul 23, 2021 - 05:40 PDT
Investigating
We are currently experiencing connection issues with the .SG registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .SG domains. Existing domains will continue to resolve normally

For a list of affected TLDs, please look the registry up in the following spreadsheet:
http://enom.help/chart
Posted Jul 23, 2021 - 05:40 PDT
This incident affected: Domain Services (Other ccTLDs).