Hostedemail
Incident Report for Enom
Resolved
Email services have been fully restored. Thank you
Posted Jul 21, 2021 - 01:12 PDT
Investigating
We are currently investigating HostedEmail service degradation. Users may be unable to Log in to webmail and may experience issues sending and receiving email.

Thank you for your patience.
Posted Jul 21, 2021 - 00:19 PDT
This incident affected: Basic Email Service.