DNS Service
Incident Report for Enom
Resolved
This incident has been resolved. DNS services are functioning as expected.
Posted 3 months ago. May 23, 2019 - 05:07 PDT
Investigating
We are currently investigating reports of sporadic issues with Enom's DNS servers. Users attempting to resolve to domains use Enom's DNS services may experience intermittent failures to resolve.

Our operations team is looking into the matter. We will provide updates as they become available.
Posted 3 months ago. May 23, 2019 - 04:53 PDT
This incident affected: DNS Service.