CM Registry
Incident Report for Enom
Resolved
The service has been completely restored. If you are still experiencing issues, please don't hesitate to contact us!
Posted Oct 08, 2018 - 14:30 PDT
Investigating
We are experiencing issues with our connection to the .CM registry. This affects the following aspects of domain management:

Availability Checks,
Whois Services,
Domain Purchases,
Domain Renewals,
Domain Updates,

DNS will continue to resolve, but changes will be unavailable at this time.
Posted Oct 07, 2018 - 17:37 PDT