Help Center and Live Chat
Incident Report for Enom
Resolved
Our Help Center and Live Chat has remained stable and our vendor has cleared this issue.
Posted 4 months ago. Jul 02, 2019 - 10:56 PDT
Monitoring
Our vendor partner confirmed a fix and we're continuing to monitor Help Center and Live Chat performance.
Posted 4 months ago. Jul 02, 2019 - 07:33 PDT
Identified
We are seeing our Help Center and Live Chat come back online now and we're keeping an eye on its stability.
Posted 4 months ago. Jul 02, 2019 - 07:24 PDT
Investigating
You may see a "502 Bad Gateway" when accessing help.enom.com. This is being promptly investigated. You can still reach our Support team via email at [email protected].
Posted 4 months ago. Jul 02, 2019 - 07:07 PDT
This incident affected: Customer Support.