Payment processing
Incident Report for Enom
Resolved
We are pleased to report that the issue that was causing transaction processing errors has been resolved and no further incidents have been reported. Thanks for bearing with us!
Posted about 1 month ago. Jul 18, 2019 - 17:10 PDT
Monitoring
A fix has been implemented for the transaction processing/billing update issue and we are now monitoring the results. Thanks for your patience!
Posted about 1 month ago. Jul 18, 2019 - 15:57 PDT
Update
We are still working to identify the root issue causing unexpected failures of billing updates or transactions. We sincerely appreciate your patience while we work to resolve this issue.
Posted about 1 month ago. Jul 18, 2019 - 15:42 PDT
Investigating
We're looking into reported errors and unexpected declines when updating billing information or attempting a credit card order. We'll keep you posted.
Posted about 1 month ago. Jul 18, 2019 - 12:33 PDT
This incident affected: Enom.com (Domain Purchase).