.TW Registry
Incident Report for Enom
Resolved
Our connection to .TW is now restored. Sorry about that!
Posted 2 months ago. Feb 09, 2019 - 08:16 PST
Investigating
Our connection to the .TW registry is currently down. The following services may be unavailable:

Availability Checks,
Whois Services,
Domain Purchases,
Domain Renewals,
Domain Updates,

DNS will continue to resolve, but changes will be unavailable at this time.
Posted 2 months ago. Feb 08, 2019 - 19:12 PST
This incident affected: Domain Services (Other ccTLDs).