Domain registrations, transfers, contact updates
Incident Report for Enom
Resolved
We've been monitoring our earlier incident surrounding contact errors and everything has been stable, so we're marking this as "Resolved". Thank you!
Posted 16 days ago. Apr 03, 2019 - 13:34 PDT
Monitoring
We temporarily had an issue resulting in errors when accessing a domain's contact information, updating a domain's contact information, registering a domain, or transferring-in a domain. This should now be resolved and we are monitoring for stability. You can now retry any orders or changes.

The approximate time of the affected period was today from 10:56 AM PT to 11:10 AM PT.
Posted 16 days ago. Apr 03, 2019 - 11:13 PDT
This incident affected: Enom.com (Domain Purchase, Domain Management).