.LA, .IT, .GS and .BR Service Degredation
Incident Report for Enom
Resolved
The issue was identified upstream with our vendor and has been corrected. This has been resolved.
Posted Mar 03, 2021 - 07:31 PST
Update
We are currently experiencing some connection issues for the following cctlds: .LA, .IT, .GS and .BR. During this time customers may have issues registering or renewing domains with this TLD. We thank you for your patience as we investigate further.
Posted Mar 03, 2021 - 06:52 PST
Investigating
We are experiencing connection issues to the registry. We will provide an update shortly with additional information.
Posted Mar 03, 2021 - 06:48 PST
This incident affected: Domain Services (Other ccTLDs).