.BIZ extended maintenance
Incident Report for Enom
Resolved
Neustar has reported they have completed maintenance.
Posted Aug 22, 2017 - 01:35 PDT
Monitoring
Neustar, the registry operator of .BIZ, is completing maintenance on their backend systems. During this time, you will not be able to register, transfer, renew, or make contact information changes to .BIZ domains. Any requests made during this period must be resubmitted once maintenance is complete. All domains will continue to resolve and function without interruption during this maintenance window.
Posted Aug 22, 2017 - 00:25 PDT