Afilias Registry Connections
Incident Report for Enom
Resolved
Connection to the Afilias registry has been restored. Domain registrations, renewals, and management should continue as normal. We thank you for your patience with this case.
Posted Sep 16, 2020 - 13:26 PDT
Investigating
We are currently experiencing connection issues with the Afilias registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of Afilias domains. Existing domains will continue to resolve normally.

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://enom.help/chart
Posted Sep 16, 2020 - 12:22 PDT
This incident affected: Domain Services (Other gTLDs).