.SG Registry Connections
Incident Report for Enom
Resolved
Our connection has been restored. Thank you for your patience.
Posted Oct 19, 2021 - 08:07 PDT
Investigating
We are currently experiencing connection issues with the .sg registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .sg domains. Existing domains will continue to resolve normally
Posted Oct 19, 2021 - 04:29 PDT
This incident affected: Domain Services (Other ccTLDs).