Incoming email
Incident Report for Enom
Resolved
This issue has been resolved, and email delivery is proceeding as normal. You may still experience minor delays as any delivery backlog clears. Thank You!
Posted 4 months ago. May 11, 2019 - 21:10 PDT
Update
We're continuing to investigate incoming email delays to understand the scope and cause of the issue.

Next update: May 11, 2019 21:30 PT
Posted 4 months ago. May 11, 2019 - 15:02 PDT
Update
We're still looking into a reported incoming email delay and hope to have news for you soon.

Next update: May 11, 2019 15:00 PT
Posted 4 months ago. May 11, 2019 - 14:30 PDT
Update
We're still looking into the degradation in our incoming hosted email performance. We'll keep you posted.

Next update: May 11, 2019 14:30 PT
Posted 4 months ago. May 11, 2019 - 14:00 PDT
Investigating
We are currently investigating a degradation affecting incoming mail to our hosted email customers. Incoming messages may be delayed or temporarily rejected. Our email operations team is on it.

Next update: Saturday, May 11, 2019 14:00 PT
Posted 4 months ago. May 11, 2019 - 13:31 PDT
This incident affected: Basic Email Service.