Error when managing G Suite subscriptions
Incident Report for Enom
Resolved
The G Suite subscription management service has been completely restored. Everything should be good to go now. If you are still experiencing issues, please don't hesitate to contact us!
Posted Jul 10, 2018 - 05:40 PDT
Update
Our development team continues to work on addressing the provisioning issue affecting some G Suite subscriptions. If the order did show as successful in your Enom account, please look for the account management email from Google to manage your G Suite services.
Posted Jul 06, 2018 - 11:13 PDT
Update
We're continuing to investigate the issue with G Suite subscription management and are working to resolve it as quickly as possible.

You may continue to see the error "Customer: Error:"deleted_client", Description:"The OAuth client was deleted.", Uri:"" when attempting to either manage an existing G Suite subscription or when trying to purchase a new G Suite subscription. Some successful orders are not provisioning to Google and we are still trying to determine the issue.

If the order did show as successful in your Enom account, please look for the account management email from Google (with management portal link https://gsuite.google.com/products/admin/) to manage your G Suite services directly with Google at this time.
Posted Jul 04, 2018 - 14:11 PDT
Investigating
Issue: We have identified an issue resulting in an error when attempting to manage G Suite subscriptions registered through Enom.

Error: "Customer: Error:"deleted_client", Description:"The OAuth client was deleted.", Uri:"""

Issue Summary: We are currently investigating the cause of this error and will update once we have more information or the incident is resolved. There is currently no workaround available.
Posted Jun 27, 2018 - 09:08 PDT
This incident affected: G Suite Email Service.