.SG Registry Connection Issue
Incident Report for Enom
Resolved
This case has been resolved. Thank you for your patience.
Posted Mar 16, 2020 - 08:35 PDT
Investigating
We are currently seeing an issue with our registry connection for .sg domains. During this time, customers may not be able to: check, register or renew .sg domains. We thank you for your patience as we get this issue fixed.
Posted Mar 16, 2020 - 06:31 PDT
This incident affected: Domain Services (Other ccTLDs).