Digicert API (Geotrust and Symantec SSL)
Incident Report for Enom
Resolved
Our connection to the Digicert API is fully restored, and all SSL actions should be functional. Thank you!
Posted 12 days ago. Apr 07, 2019 - 13:42 PDT
Update
DigiCert has confirmed that while their maintenance has completed, They are still experiencing intermittent problems. We will continue to monitor the situation and provide updates as they become available.
Posted 12 days ago. Apr 07, 2019 - 03:09 PDT
Update
We are continuing to monitor for any further issues.
Posted 12 days ago. Apr 06, 2019 - 21:49 PDT
Monitoring
Digicert has confirmed that their maintenance is ongoing longer than expected. They're unable to provide a specific end point at this time, but are aiming to finish within the hour. We will continue to monitor the situation and provide you updates.

Thank you for your patience.
Posted 12 days ago. Apr 06, 2019 - 21:38 PDT
Investigating
We are receiving reports that the Digicert API is still down, though the scheduled maintenance was reported as completed. At this time, Certificate Lifecycle operations (e.g. configure, approve, and revoke certificates) will be unavailable. This will affect GeoTrust and Symantec SSLs purchased through Enom.

We are looking into this issue and will update you the moment we have more info to provide.
Posted 12 days ago. Apr 06, 2019 - 21:27 PDT
This incident affected: SSL Certificates.