Geotrust Order Processing Issue
Incident Report for Enom
Resolved
We have confirmed with Geotrust the order processing delays have been resolved.

Thank you for your patience.
Posted 5 days ago. Sep 10, 2019 - 13:01 PDT
Update
We are speaking with Geotrust to confirm the current status of delays and will update once we have further information.
Posted 5 days ago. Sep 10, 2019 - 12:16 PDT
Update
We've checked in with Geotrust, and they confirmed the order processing delay is still ongoing on their end. If you have an SSL submission that appears to be stuck in "Processing" status, and you have not received your certificate files, reach out to our Support team.

Next update: 12:00 PDT
Posted 6 days ago. Sep 10, 2019 - 07:29 PDT
Monitoring
We have been advised by Geotrust that some of their orders are being approved, but will then get stuck in their system.

They have escalated this issue to their engineering team, but there are still some orders which are affected.
Posted 6 days ago. Sep 09, 2019 - 18:46 PDT