Comodo certificate outage
Incident Report for Enom
Resolved
Comodo has confirmed that connection issue has been resolved. Comodo Certificate services should no longer encounter any issues.
Posted May 12, 2017 - 09:46 PDT
Identified
Comodo has confirmed they are having an outage.
They are estimating a repair window of at least a few hours.
We will continue to update you with new information as it becomes available.
All Comodo certificates may experience issues being submitted or configured with various errors.
Posted May 11, 2017 - 10:53 PDT