DNS Update Delays
Incident Report for Enom
Resolved
This incident has been resolved.
Posted May 16, 2022 - 15:15 PDT
Update
Our engineers were able to confirm that everything is working as expected. We have run additional tests and confirmed that records are currently propagating without delay. All services are functioning as expected at this time.

Thank you for your patience!
Posted May 16, 2022 - 15:14 PDT
Update
We are continuing to investigate this issue.
Posted May 16, 2022 - 15:13 PDT
Investigating
We are currently investigating reports of delays to record updates while using Enom DNS. Updates to existing records as well as new record creations may be delayed.
Posted May 16, 2022 - 11:54 PDT
This incident affected: DNS Service.