Credit card payments
Incident Report for Enom
Resolved
The payment failure alerts from overnight and earlier this morning have cleared, and the system has been stable for a few hours now, so we're considering this resolved. Please retry any failed credit card updates, refills, or orders, and reach out to our Support team if you still require assistance.
Posted 17 days ago. Aug 01, 2019 - 08:06 PDT
Monitoring
We are no longer seeing credit card or payments related alerts. We'll keep this incident open for a bit longer to monitor.
Posted 17 days ago. Aug 01, 2019 - 06:12 PDT
Identified
We have identified a connection issue with our credit card vendor which may affect ability to update credit cards or make credit card payments. We'll keep you posted.

Next update: 06:00 PDT
Posted 17 days ago. Aug 01, 2019 - 04:51 PDT
This incident affected: Enom.com (Domain Purchase).