Domain Renewal Issue in Enom
Incident Report for Enom
Resolved
This issue has now been resolved. Please reach out to support if your run into any furhter issues.
Posted Sep 17, 2018 - 15:44 PDT
Monitoring
Our dev team has pushed a bug fix for this issue. If you were having renewal issues previously, please try submitting another order. We will keep testing on our end and update once this issue is fully resolved.
Posted Sep 17, 2018 - 13:45 PDT
Investigating
We are currently looking into an issue where domain renewals are not completing through the Enom cart.

We are working with our dev team to get this resolved. Thank you for your patience.
Posted Sep 17, 2018 - 12:38 PDT
This incident affected: Domain Services (Core gTLDs, Core ccTLDs, Other gTLDs, Other ccTLDs).