DNS Services degradation
Incident Report for Enom
Resolved
All the services have recovered successfully, we will be closing this incident.

Duration: 4 hours 22 minutes

6:38 AM PST
11:01 AM PST
Posted Sep 19, 2020 - 11:02 PDT
Investigating
We are still working to mitigate DDOS, at this time enom.com is currently unreachable.
Posted Sep 19, 2020 - 10:26 PDT
Monitoring
Mitigation continues, we have not experienced any slowness at this time but will continue to monitor the situation.
Posted Sep 19, 2020 - 10:03 PDT
Investigating
We are currently experiencing a volumetric DDOS attack on our services, our engineering team is working to mitigate. Some DNS services may experience degraded performance. We will continue to update as new information comes in.

Start time: 6:38 AM PST
Posted Sep 19, 2020 - 09:31 PDT
This incident affected: Enom.com (Website, Domain Search, Domain Purchase, Domain Management) and DNS Service.