CentralNIC Registry Connections
Incident Report for Enom
Resolved
Our connection to the CentralNIC Registry is fully restored and working as intended.

We thank you for your patience while we worked to resolve this.
Posted May 31, 2020 - 16:50 PDT
Update
.uno has been restored to full service. However, .ceo and .best are still impacted. We will update you with any new info.
Posted May 31, 2020 - 04:13 PDT
Investigating
We are currently experiencing connection issues with the CentralNIC registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .uno, .ceo, and .best domains. Existing domains will continue to resolve normally
Posted May 30, 2020 - 22:04 PDT
This incident affected: Domain Services (Other gTLDs).