Enom DNS Record Propagation Delays
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Aug 05, 2022 - 09:36 PDT
Monitoring
Our team has implemented a fix. Domain propagation should function as expected for new updates. We will continue to monitor the case to make sure that there are no further issues.
Posted Aug 05, 2022 - 08:28 PDT
Investigating
We are currently experiencing delays in DNS record propagation on the Enom platform. Our Engineering team has been engaged to investigate and work on a fix. We thank you for your patience on this case.
Posted Aug 05, 2022 - 08:06 PDT
This incident affected: DNS Service.