Enom Credit Card Billing Issue
Incident Report for Enom
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 21, 2019 - 04:48 PDT
Monitoring
We have received confirmation from our dev team that they have fixed the issue. If you were previously running into errors, please try updating your card again on your account. We thank you for your patience with this issue.
Posted 4 months ago. Jun 20, 2019 - 11:42 PDT
Identified
Our Dev team has found more information regarding this issue, and are seeing some more orders going through successfully. We will provide another update once we can confirm that this issue is fully resolved.

Thank you for your continued patience.
Posted 4 months ago. Jun 20, 2019 - 09:54 PDT
Update
Our development and billing teams are still looking into the matter with declined or failing credit card payments. We apologize for any inconvenience this may be causing. We will update you as soon as any new info is made available.
Posted 4 months ago. Jun 18, 2019 - 21:42 PDT
Investigating
We are currently seeing multiple instances of credit card payments being declined or failing in our system. We are looking into this issue with our dev and billing team. We appreciate your patience on this matter.
Posted 4 months ago. Jun 18, 2019 - 09:31 PDT
This incident affected: Enom.com (Domain Purchase).