Enom Support Live Chat Degraded Service
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Sep 21, 2020 - 12:46 PDT
Monitoring
Live chat should be working again for customers. We will continue to monitor the situation but it should be back up and running in the help center.
Posted Sep 21, 2020 - 10:03 PDT
Investigating
We are currently looking into an issue with our live chat where customers are not able to access chat through our help center or are getting their chats closed automatically. While we are getting this issue resolved please reach out if you need support via Email or toll-free number: 1-855-266-8838
Posted Sep 21, 2020 - 09:40 PDT
This incident affected: Customer Support.