.DE Registry Connections
Incident Report for Enom
Resolved
We are happy to report that the connections to the .DE registry have been restored
Posted 5 months ago. Feb 04, 2019 - 12:01 PST
Investigating
We are currently experiencing connection issues with the .DE registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .DE domains. Existing domains will continue to resolve normally.
Posted 5 months ago. Feb 04, 2019 - 11:18 PST