Registering newly-released .UK "Rights of Registration" domains
Incident Report for Enom
Resolved
We've resolved the reason why the first batch of released .UK domains were initially not listed as available for registration, sorry about that!

Reach out to our Support department if you need any further help getting your domain.
Posted 4 months ago. Jul 01, 2019 - 11:18 PDT
Investigating
We are currently investigating why the first batch of "Rights of Registration"-released .UK domains are not showing as available for registration in our domain lookup. We'll keep you posted.
Posted 4 months ago. Jul 01, 2019 - 07:42 PDT
This incident affected: Domain Services (Core ccTLDs).