Plesk Web Hosting ehost-services230.com service interruption
Incident Report for Enom
Resolved
The issues we were having earlier with our hosting server ehost-services230.com have been resolved.

Thank you for your patience while we worked to resolve this.
Posted 2 months ago. Mar 14, 2019 - 18:11 PDT
Investigating
We are currently investigating an outage on ehost-services230.com. The Plesk administrative panel and websites hosted on this server may not respond.
Posted 2 months ago. Mar 14, 2019 - 10:03 PDT
This incident affected: Web Hosting Service.