Hosted email
Incident Report for Enom
Resolved
The issue impacting access to Enom webmail and accessing emails via IMAP/POP connections has now been resolved.

We are not getting reports of new issues and our testing has confirmed that the issue is resolved. Thanks for your patience while we took care of this!
Posted 17 days ago. Aug 01, 2019 - 12:27 PDT
Monitoring
Our operations team has isolated the issue to faulty routing with the upstream network. The number of impacted users should start decreasing.
Posted 17 days ago. Aug 01, 2019 - 11:24 PDT
Update
Currently, some Enom email customers may experience issues when signing into Webmail or accessing their emails through a POP/IMAP connection.

Our operations teams are continuing to work to resolve the impact of the interruptions which seem to reside outside of our network. Thank you for your patience, and as we receive additional information we will post more details.

Next update: 11:00AM PDT
Posted 17 days ago. Aug 01, 2019 - 09:49 PDT
Investigating
Some users, especially those located in Europe or Africa, may not be able to connect to our hosted email (webmail, POP, or IMAP). We're looking into it.
Posted 17 days ago. Aug 01, 2019 - 05:11 PDT
This incident affected: Basic Email Service.