.EU Registry Maintenance
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Aug 23, 2017 - 00:37 PDT
Monitoring
EURID, the .EU registry, is currently undergoing scheduled maintenance. This maintenance is scheduled to last until 3:00 PM PST 8/23/17. During this time, all functions related to .EU registration and management will be down.
Posted Aug 22, 2017 - 23:51 PDT