Delayed automated system emails (verification emails, password reset links)
Incident Report for Enom
Resolved
The delays we were previously experiencing with outbound system emails have now cleared and all queued emails have been sent. Thanks for bearing with us.
Posted Sep 13, 2018 - 09:27 PDT
Investigating
We are investigating reports of delayed outbound system emails, including domain verification emails and account password reset links. Our team is looking into the cause and we'll update you once we know more.
Posted Sep 13, 2018 - 08:00 PDT