New Email Creation Issue
Incident Report for Enom
Resolved
We identified and repaired the source of the error when making new mailboxes, and now we're good to go! Thanks for bearing with us.
Posted 17 days ago. Aug 29, 2019 - 11:04 PDT
Update
We are continuing to investigate the cause of errors when creating mailboxes on domains new to hosted email. Please stand by while we dig into this.

Next update: 12:00 PDT
Posted 17 days ago. Aug 29, 2019 - 10:49 PDT
Investigating
We are currently experiencing issues creating Email accounts. Mailboxes already existing will not be impacted. We are investigating the issue.
Posted 17 days ago. Aug 29, 2019 - 09:48 PDT
This incident affected: Basic Email Service.