Some support calls not routing correctly
Incident Report for Enom
Resolved
We are no longer seeing issues with inbound calls. Thank you for your patience on this matter.
Posted Sep 06, 2018 - 15:47 PDT
Monitoring
The issue with our inbound phone support line was identified and repaired. We are now seeing recovery and monitoring the results.
Posted Sep 06, 2018 - 14:27 PDT
Investigating
We are currently investigating an issue with our inbound phone center not routing all calls correctly. We will update you as soon as we know more.
Posted Sep 06, 2018 - 14:07 PDT
This incident affected: Customer Support.