Payment Processing
Incident Report for Enom
Resolved
This incident has been resolved, we haven't had any reported problems in some time after the fix was implemented.

Incident start time: 12:30 AM PST
Incident close time: 5:52 AM PST

Length 5 hours and 22 minutes
Posted Nov 19, 2020 - 05:53 PST
Monitoring
A fix has been implemented, we are monitoring the results before resolving this incident.
Posted Nov 19, 2020 - 05:17 PST
Identified
We are continuing investigation of Payment Processing errors. We will provide updates as they become available. Thank you for your patience.
Posted Nov 19, 2020 - 03:49 PST
Investigating
We are currently seeing an interruption in Credit Card/Debit Card payment processing.

During this time any Credit Card/Debit Card orders that you may try to process in your account may fail. At the moment, we do not recommend retrying your transaction until resolved.

Our dev team is working to get this fixed as soon as possible. We appreciate your patience.
Posted Nov 19, 2020 - 00:30 PST
This incident affected: Enom.com (Website, Domain Purchase) and API.