Email Service Degraded
Incident Report for Enom
Resolved
This incident has been resolved.
Posted Jul 29, 2020 - 17:25 PDT
Monitoring
Our team has resolved the root cause and email services are now working as intended.

We will monitor this fix for the next while to ensure there are no further issues.

Thank you again for your patience.
Posted Jul 29, 2020 - 16:35 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 29, 2020 - 16:04 PDT
Update
Our team is continuing to work towards a resolution to the email issues currently being seen.

We will provide additional updates as they become available.
Posted Jul 29, 2020 - 14:53 PDT
Investigating
We are currently investigating reports of users being unable to utilize their email services as anticipated.

Users may experience inbound email delivery delays, slowness or timeouts while accessing their email.

Thank you for your patience.
Posted Jul 29, 2020 - 13:43 PDT
This incident affected: Basic Email Service.