Email Delay
Incident Report for Enom
Resolved
Our operations team was able to resolve the issues we were seeing for our Enom email customers.

We thank you for your patience while this was worked on.
Posted 5 months ago. Feb 05, 2019 - 15:04 PST
Identified
We are currently experiencing a delay with incoming email delivery for Enom email customers.

Our operations team is working to resolve this issue at this time.

Thank you for your patience while we work towards a resolution for this issue.
Posted 5 months ago. Feb 05, 2019 - 14:55 PST
This incident affected: Basic Email Service.