Hosted email
Incident Report for Enom
Resolved
This issue has been resolved. We appreciate your patience with this matter.
Posted Nov 04, 2019 - 06:20 PST
Update
We are still looking into why users from the UK, France, and US (ISP: Optimum) are having difficulty reaching our hosted email service. We will update you with new information as soon as possible.
Posted Nov 02, 2019 - 21:13 PDT
Update
We are still investigating why some users from the UK, France, and US (ISP: Optimum) can't reach our hosted email service.
Posted Nov 02, 2019 - 10:41 PDT
Investigating
We are investigating a potential routing issue affecting the email connectivity of some users, mostly in the UK. We'll keep you posted.
Posted Nov 02, 2019 - 06:18 PDT
This incident affected: Basic Email Service.