Inbound Support Calls
Incident Report for Enom
Resolved
This issue has been resolved.
Posted Jan 12, 2021 - 08:28 PST
Monitoring
The inbound call issue has been resolved and our phone support services are operational. We will continue to monitor for any further outages.
Posted Jan 12, 2021 - 07:56 PST
Identified
We are currently experiencing issues with our inbound support phone service. The issue has been identified as upstream with our vendor and we are monitoring for further updates.

If you are unable to connect via the phone, please open a chat or create a ticket within our helpcenter.

Thank you for your patience.
Posted Jan 12, 2021 - 06:57 PST
This incident affected: Customer Support.