.TW Registry Connections
Incident Report for Enom
Resolved
No further issues have been encountered. Thank you for your patience.
Posted Dec 07, 2022 - 07:59 PST
Monitoring
Our connection has been restored. We will continue to monitor for further issues.
Posted Dec 07, 2022 - 07:21 PST
Investigating
We are currently experiencing connection issues with the .TW registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .TW domains. Existing domains will continue to resolve normally
Posted Dec 07, 2022 - 04:59 PST
This incident affected: Domain Services (Other ccTLDs).