.NL Registry Scheduled Maintenence
Incident Report for Enom
Resolved
.NL registry Maintenance has been completed and connectivity restored.
Posted Aug 14, 2017 - 23:01 PDT
Identified
The .nl registry is upgrading the technical infrastructure of the .nl TLD. As a result, the Whois and certain other services will be temporarily unavailable.
Posted Aug 14, 2017 - 22:13 PDT