WHOIS lookup and domain contact management
Incident Report for Enom
Resolved
We are happy to report the issues have been resolved. All services are now operational. Thank you.
Posted 2 months ago. Apr 10, 2019 - 10:57 PDT
Monitoring
We identified and corrected the issue which impacted WHOIS lookups and contacts-related actions, and we are now monitoring for stability.

Next update: April 10, 2019 11:00 PT
Posted 2 months ago. Apr 10, 2019 - 10:04 PDT
Investigating
We are currently investigating failures with our WHOIS lookups and contact management. This may affect domain contact updates, registrations, and transfers.

Next update: April 10, 2019 10:00 AM PT
Posted 2 months ago. Apr 10, 2019 - 09:31 PDT
This incident affected: Enom.com (Domain Purchase, Domain Management).