Enom Billing Issues
Incident Report for Enom
Resolved
This incident has been resolved.

Thank you again for your patience.
Posted Jun 18, 2020 - 15:47 PDT
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Thank you for your patience.
Posted Jun 18, 2020 - 14:21 PDT
Investigating
We are currently looking into an issue that is affecting some customer's ability to process orders from their Enom cart. Customers may see a pre-authorization error when trying to make transactions despite their billing information being correct. We thank you for your patience as we work on a fix for this case.
Posted Jun 18, 2020 - 13:10 PDT
This incident affected: Enom.com (Domain Purchase).