.eu Registry Connection Issues
Incident Report for Enom
Resolved
We have fully restored connectivity with the .EU registry. You can now retry any previously failed .EU registrations, renewals, or transfers. Thanks for bearing with us.
Posted Dec 05, 2019 - 04:55 PST
Identified
We have identified the issue and are waiting for the fix to be finalised. Thank you for your patience on this case, we hope to have it resolved soon.
Posted Dec 04, 2019 - 10:11 PST
Update
We are continuing to work on this case with our dev team. We appreciate your continued patience.
Posted Dec 04, 2019 - 07:29 PST
Update
This case is still being looked into. Thank you for your continued patience.
Posted Dec 03, 2019 - 10:24 PST
Update
We are still working with the registry to get this issue resolved. We appreciate your continued patience.
Posted Dec 03, 2019 - 06:10 PST
Update
We are still working to resolve this issue.

Thank you for your continued patience.
Posted Dec 02, 2019 - 21:39 PST
Update
This issue is still being worked on, we appreciate your continued patience.
Posted Dec 02, 2019 - 10:33 PST
Update
We are still working to get this issue resolved. We appreciate your continued patience with this case.
Posted Dec 02, 2019 - 08:33 PST
Investigating
We are currently looking into a .eu connection issue with the registry. During this time, customers may have issues registering/ renewing .eu domains. We apologize for the inconvenience and will provide any updates as they happen.
Posted Dec 02, 2019 - 05:58 PST
This incident affected: Domain Services (Core ccTLDs).