Sectigo certificates
Incident Report for Enom
Resolved
You should no longer encounter "(404) Not Found" errors while configuring Sectigo SSL certificates. Sorry about the blip! Please do let us know if you notice anything else unusual.
Posted 6 days ago. Sep 09, 2019 - 11:20 PDT
Identified
We have identified the cause of the "(404) Not Found" errors when configuring Sectigo SSL certificates and are working to implement a fix.
Posted 6 days ago. Sep 09, 2019 - 09:54 PDT
Investigating
Some users are experiencing "(404) Not Found" errors when configuring Sectigo SSL certificates. We're looking into this.
Posted 6 days ago. Sep 09, 2019 - 08:58 PDT
This incident affected: SSL Certificates.