Email Service Degraded
Incident Report for Enom
Resolved
The issue we saw earlier with Email Services has now been fully resolved.

Thank you for your patience.
Posted Jul 23, 2020 - 18:30 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2020 - 17:54 PDT
Investigating
We are seeing reports of some users being unable to use their email services as expected.

Our team is actively looking into this and we will provide updates as they become available.
Posted Jul 23, 2020 - 17:20 PDT
This incident affected: Basic Email Service.